给定一个 n 个点 m 条边的有向图,图中可能存在重边和自环。
所有边的长度都是 1,点的编号为 1∼n。
请你求出 1号点到 n 号点的最短距离,如果从 1 号点无法走到 n 号点,输出 −1。
输入格式
第一行包含两个整数 n 和 m。
接下来 m 行,每行包含两个整数 a 和 b,表示存在一条从 a 走到 b 的长度为 1 的边。
输出格式
输出一个整数,表示 1 号点到 n 号点的最短距离。
数据范围
1≤n,m≤105
输入样例:
4 5
1 2
2 3
3 4
1 3
1 4
输出样例:
1
思路
类型:带环的权重一致的最短路问题
类似与走迷宫问题,从数组变成了图,其它基本一致。
import java.util.*;
public class Main {
static int n, m, idx;
static int[] h, e, ne;
static int[] dist;
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
n = sc.nextInt();
m = sc.nextInt();
h = new int[n + 1];
Arrays.fill(h, -1);
e = new int[m];
ne = new int[m];
dist = new int[n + 1];
while (m-- > 0) {
int a, b;
a = sc.nextInt();
b = sc.nextInt();
add(a , b);
}
bfs();
System.out.println(dist[n]);
}
static void add(int a, int b) {
e[idx] = b;
ne[idx] = h[a];
h[a] = idx++;
}
static void bfs() {
Arrays.fill(dist, -1);
dist[1] = 0;
Queue<Integer> q = new LinkedList<>();
q.offer(1);
while (!q.isEmpty()) {
int cur = q.poll();
for (int i = h[cur]; i != -1; i = ne[i]) {
int j = e[i];
if (dist[j] == -1) {
dist[j] = dist[cur] + 1;
q.offer(j);
}
}
}
}
}