存储结构
- 开放寻址法(又名“蹲坑法”)
- 拉链法
操作类型
- 添加
- 查找
- 删除(很少有,而且删除不是严格意义上的删除,只是打一个标记)
作用
将大的数据范围映射到小的值域
如何实现
- 哈希函数,一般用取模运算
- 冲突处理
- 拉链法
- 开放寻址法
- 线性探查法(即当前坑位被占,向后挪一位继续探测)
- 二次探查法(即当前坑位被占,向后挪
i*i
位,注意取模,i
从0开始递增)
维护一个集合,支持如下几种操作:
I x
,插入一个数 x;Q x
,询问数 x 是否在集合中出现过;
现在要进行 N 次操作,对于每个询问操作输出对应的结果。
输入格式
第一行包含整数 N,表示操作数量。
接下来 N行,每行包含一个操作指令,操作指令为 I x
,Q x
中的一种。
输出格式
对于每个询问指令 Q x
,输出一个询问结果,如果 x 在集合中出现过,则输出 Yes
,否则输出 No
。
每个结果占一行。
数据范围
1≤N≤105
−109≤x≤109
输入样例:
5
I 1
I 2
I 3
Q 2
Q 5
输出样例:
Yes
No
拉链法
插入:用一个数组存储链表的头指针,根据元素的哈希值找到对应位置的链表,然后采用头插法插入即可。
查询:查询时也是一样的哈希操作,找到该元素对应的应该被存储的链表,遍历链表找该节点,存在返回true,不存在返回false
数组的长度与具体问题有关。一般来讲输入的规模与数组的长度差不多
这里数组长度取质数
import java.util.*;
import java.io.*;
public class Main {
static final int N = 100003;
static ListNode[] list = new ListNode[N];
public static void main(String[] sss) throws IOException{
BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
BufferedWriter bw = new BufferedWriter(new OutputStreamWriter(System.out));
int n = Integer.parseInt(br.readLine());
while (n-- > 0) {
String[] str = br.readLine().split(" ");
int x = Integer.parseInt(str[1]);
if (str[0].equals("I")) insert(x);
else {
if (query(x)) bw.write("Yes\n");
else bw.write("No\n");
}
}
br.close();
bw.close();
}
static void insert(int x) {
//找到应该插入的链表
int k = ((x % N) + N) % N;
if (list[k] == null) {
list[k] = new ListNode(x);
}
else {
ListNode node = new ListNode(x, list[k].next);
list[k].next = node;
}
}
static boolean query(int x) {
int k = ((x % N) + N) % N;
ListNode cur = list[k];
while (cur != null) {
if (cur.val == x) return true;
cur = cur.next;
}
return false;
}
}
class ListNode {
int val;
ListNode next;
ListNode(int x) {
this.val = x;
}
ListNode(int x, ListNode next) {
this.val = x;
this.next = next;
}
}
蹲坑法
开辟一个输入规模两到三倍的数组存储输入元素,用一个输入中不存在的元素NONE
作为空的记录
插入和查找用一个函数 find()
完成,find
返回数组的下标
将元素哈希,找到对应坑位,如果该坑已经有元素,继续向后寻找直至找到一个空位置或者某个坑位的元素值与该元素相同,返回对应的数组下标
如果是插入:h[find(x)] = x
如果是查询:h[find(x)] == NONE
,如果相等说明该元素不存在。
import java.util.*;
import java.io.*;
public class Main {
static final int N = 200003, NONE = 0x3f3f3f3f;
static int[] h = new int[N];
static {
//用NONE初始化h
Arrays.fill(h, NONE);
}
public static void main(String[] sss) throws IOException{
BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
BufferedWriter bw = new BufferedWriter(new OutputStreamWriter(System.out));
int n = Integer.parseInt(br.readLine());
while (n-- > 0) {
String[] str = br.readLine().split(" ");
int x = Integer.parseInt(str[1]);
if (str[0].equals("I")) h[find(x)] = x;
else {
if (h[find(x)] == NONE) bw.write("No\n");
else bw.write("Yes\n");
}
}
br.close();
bw.close();
}
//线性探查法
static int find(int x) {
int k = ((x % N) + N) % N;
for (int i = k; ; i++) {
if (i == N) i = 0;
if (h[i] == NONE || h[i] == x) return i;
}
}
}
开放地址法解决冲突采用二次探测法的例题:
1564. 哈希