批改多选题是比较麻烦的事情,本题就请你写个程序帮助老师批改多选题,并且指出哪道题错的人最多。
输入格式:
输入在第一行给出两个正整数 N(≤ 1000)和 M(≤ 100),分别是学生人数和多选题的个数。随后 M 行,每行顺次给出一道题的满分值(不超过 5 的正整数)、选项个数(不少于 2 且不超过 5 的正整数)、正确选项个数(不超过选项个数的正整数)、所有正确选项。注意每题的选项从小写英文字母 a 开始顺次排列。各项间以 1 个空格分隔。最后 N 行,每行给出一个学生的答题情况,其每题答案格式为 (选中的选项个数 选项1 ……)
,按题目顺序给出。注意:题目保证学生的答题情况是合法的,即不存在选中的选项数超过实际选项数的情况。
输出格式:
按照输入的顺序给出每个学生的得分,每个分数占一行。注意判题时只有选择全部正确才能得到该题的分数。最后一行输出错得最多的题目的错误次数和编号(题目按照输入的顺序从 1 开始编号)。如果有并列,则按编号递增顺序输出。数字间用空格分隔,行首尾不得有多余空格。如果所有题目都没有人错,则在最后一行输出 Too simple
。
输入样例:
3 4
3 4 2 a c
2 5 1 b
5 3 2 b c
1 5 4 a b d e
(2 a c) (2 b d) (2 a c) (3 a b e)
(2 a c) (1 b) (2 a b) (4 a b d e)
(2 b d) (1 e) (2 b c) (4 a b c d)
输出样例:
3
6
5
2 2 3 4
代码
测试点4未通
#include<cstdio>
#include<cstring>
struct Problem {
int itemNum;
int score;
int correctNum;
char answer[6];
Problem() {
for (int i = 0; i < 6; i++)
answer[i] = { '\0' };
}
};
struct Student {
int score;
int itemNum;
int correctNum;
Student() {
score = 0;
itemNum = 0;
correctNum = 0;
}
};
int main() {
int stuNum, problemNum;
scanf("%d%d", &stuNum, &problemNum);
/** Read the problem information */
Problem* pro = new Problem[problemNum];
for (int i = 0; i < problemNum; i++) {
scanf("%d%d%d", &pro[i].score, &pro[i].itemNum, &pro[i].correctNum);
int temp = 0;
while (temp != pro[i].correctNum)
scanf(" %c", &pro[i].answer[temp++]);
}
int* statistics = new int[problemNum];
for (int i = 0; i < problemNum; i++) { /* Initialize the statistics array */
statistics[i] = 0;
}
/** Read the student information */
Student* stu = new Student[stuNum];
int wrongCounter = 0;
for (int i = 0; i < stuNum; i++) {
char stuAns[10001] = {'\0'};
getchar(); /* Absort the '\n' */
scanf("%[^\n]", stuAns);
for (int j = 0; j < problemNum; j++) {
stu[i].itemNum = 0;
stu[i].correctNum = 0;
sscanf(stuAns, "(%d", &stu[i].itemNum);
if (stu[i].itemNum != pro[j].correctNum) {
stu[i].score += 0;
statistics[j]++;
wrongCounter++;
continue;
}
char stuItem[101] = {'\0'}; /* Read the student's each item */
sscanf(stuAns, "%[^')']", stuItem);
for (int k = 0; k < strlen(stuItem); k++) {
if (stuItem[k] >= 'a' && stuItem[k] <= 'z') {
for (int x = 0; x < pro[j].correctNum; x++) {
if (stuItem[k] == pro[j].answer[x]) {
stu[i].correctNum++;
break;
}
}
}
}
strcpy(stuAns, stuAns + (stu[i].itemNum * 2 + 4)); /* Pointer move right to next problem */
if (stu[i].correctNum == pro[j].correctNum)
stu[i].score += pro[j].score;
else {
stu[i].score += 0;
statistics[j]++;
wrongCounter++;
}
}
printf("%d\n", stu[i].score);
}
int MAX = 0;
for (int i = 0; i < problemNum; i++) {
if (statistics[i] > MAX) MAX = statistics[i];
}
if (wrongCounter) {
printf("%d", MAX);
for (int i = 0; i < problemNum; i++)
if (statistics[i] == MAX) printf(" %d", i + 1);
}
else
printf("Too simple\n");
delete[] pro;
delete[] stu;
return 0;
}