给定一颗树,树中包含 n 个结点(编号 1∼n)和 n−1条无向边。
请你找到树的重心,并输出将重心删除后,剩余各个连通块中点数的最大值。
重心定义:重心是指树中的一个结点,如果将这个点删除后,剩余各个连通块中点数的最大值最小,那么这个节点被称为树的重心。
输入格式
第一行包含整数 n,表示树的结点数。
接下来 n−1 行,每行包含两个整数 a和 b,表示点 a 和点 b 之间存在一条边。
输出格式
输出一个整数 m,表示将重心删除后,剩余各个连通块中点数的最大值。
数据范围
1≤n≤105
输入样例
9
1 2
1 7
1 4
2 8
2 5
4 3
3 9
4 6
输出样例:
4
思路:
使用邻接表存储树
深度优先搜索求树中每个节点作为被删除节点的最大连通块,用一个全局变量保存个节点最大连通块中的最小值。
作为被删除节点的每个节点的连通块的组成:
- 父节点组成的连通块
- 每个子树构成一个连通块
具体做法:
- 深搜每个节点,用
st
记录已经被搜索过的节点 - 记录该节点各子树的最大连通块
res
,同时记录以该节点为根节点的连通块的节点数sum
- 找到该节点各子树最大连通块后与父节点组成的连通块数进行比较得到删除该节点后的最大连通块数,更新全局变量
ans
import java.util.*;
public class Main {
static int n, idx;
static int[] h, e, ne;
static int ans = Integer.MAX_VALUE;
static boolean[] st;
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
n = sc.nextInt();
h = new int[n + 1];
Arrays.fill(h, -1);
e = new int[n * 2];
ne = new int[n * 2];
st = new boolean[n + 1];
int m = n - 1;
while (m-- > 0) {
int a = sc.nextInt(), b = sc.nextInt();
add(a, b);
add(b, a);
}
dfs(1);
System.out.println(ans);
}
static int dfs(int u) {
st[u] = true;
int sum = 1, res = 0;
for (int i = h[u]; i != -1; i = ne[i]) {
int j = e[i];
if (st[j]) continue;
int s = dfs(j);
res = Math.max(res, s);
sum += s;
}
res = Math.max(res, n - sum);
ans = Math.min(res, ans);
return sum;
}
static void add(int a, int b) {
e[idx] = b;
ne[idx] = h[a];
h[a] = idx ++;
}
}