1、5大工作模式及命令

第一次配置网络设备,需要使用console线
在PC需要使用“超级终端”或其他软件。

1)用户模式:

switch>
可以查看交换机的基本简单信息,且不能做任何修改配置!

2)特权模式:

switch> enable
switch#
可以查看所有配置,且不能修改配置
但可以做测试、保存、初始化等操作

3)全局配置模式:

switch# configure terminal
switch(config)#
默认不能查看配置!
可以修改配置,且全局生效!

4)接口配置模式:

switch(config)# interface f0/1
switch(config-if)#
默认不能查看配置!
可以修改配置,且对该端口生效!

5)console口/线/控制台模式:

默认不能查看配置!
可以修改配置,且对console口生效!

2、基本命令

退出一级

exit

直接退到特权模式

end

配置主机名

conf t
hostname 设备名

设置用户密码

line co 0
password 密码
login
exit

保存配置

en
copy running-config startup-config

write

查看running-config配置

en
show running-config
sh run

查看startup-config配置

show startup-config

重启设备

en
reload

配置特权密码

conf t
enable password 密码 (明文)
enable secret 密码 (密文)

查看MAC地址表

show mac-address-table

查看接口状态列表

show ip int brief
简写:sh ip int b

手工关闭接口

int f0/x
shutdown
exit

手工开启接口

int f0/x
no shutdown
exit

do的用法

其他模式加do空格可以强制使用特权模式的命令
如:
do sh run
do sh ip int b
do wr

删除配置

1)在哪配置的,就在哪删!
2)命令前加no空格
3)原命令中有参数,并且参数具有唯一性,则
删除时不需要加参数
如:
conf t
hostname sw1

conf t
no hostname

清空/擦除/初始化配置

en
erase startup-config

为3层端口配置IP

int f0/0
ip add 10.1.1.254 255.255.255.0
no shut #三层端口默认没有启用端口,需要手动开启
exit

开启远程控制

conf t
line vty 0 4 # 最多可以同时连接五个终端
transport input telnet/ssh/none/all
password 密码
login
exit

ssh服务需要密钥对
conf t
hostname r1
ip domain-name r1.qf.com
crypto key generate rsa 生成密钥对!
line vty 0 4
transport input telnet/ssh/none/all
login local # 启用本地账户和密码
exit
username xx password 123.com # 创建本地创建和密码
image.png

image.png

为交换机配置管理IP

conf t
int vlan 1
ip add 10.1.1.253 255.255.255.0
no shut

为交换机配置默认网关

目的:可被跨网段管理!
conf t
ip default-gateway 10.1.1.254

关闭自动解析功能

conf t
no ip domain-lookup

创建VLAN:

conf t
vlan ID,ID,ID-ID # 如 vlan 10
[name 自定义名称] # 自定义名字,可以不输入
exit

查看VLAN表:

show vlan b

将端口加入到VLAN:

int f0/x
switchport access vlan ID
exit

配置trunk命令:

int f0/x
[switchport trunk encapsulation dot1q/isl]`` # 选用标签协议,不支持的话 默认使用802.1q协议( dot1q)
switchport mode trunk
exit

3、三层交换机

1.三层交换机 = 三层路由+二层交换机
2.三层路由引擎是可以关闭或开启的
conf t
ip routing 开启三层路由功能
no ip routing 关闭三层路由功能
3.三层交换机的优点:
与单臂路由相比:
1)解决了网络瓶颈问题
2)解决了单点故障(虚拟接口不再依赖任何的物理接口)
3)一次路由,永久交换

4.三层交换机上起虚接口(配置VLAN的网关)
int vlan 10
ip add 10.1.1.254 255.255.255.0
no shut
exit

5.二层端口升级为三层端口
int f0/x
no switchport
ip add …
no shut